Biblioboite

De fabriques Numériques
Aller à : Navigation, rechercher

Sommaire


{{#if:|}}

Description :

Inspirée par les radios pirates et le mouvement de la culture libre, la Biblioboîte est adaptée de la LibraryBox, elle même adaptée de la Piratebox créée par David Darts, un dispositif mobile et autonome de partage de fichiers.

A quoi ça sert ?

Comme une médiathèque physique, la biblioboîte permet de partager, diffuser, redécouvrir des oeuvres de qualité du domaine public ou placées sous licences Creative Commons.

Le tutoriel présenté ici, rassemble l’ensemble des informations trouvées sur la création d’une PirateBox qui nous ont permis de créer notre biblioboîte. Nous partageons à notre tour nos fichiers de configuration modifiés pour nos besoins.

Nous nous sommes largement appuyé sur le travail de David Darts pour la première partie de ce tutoriel sur l’installation de la Piratebox :

  • http://daviddarts.com/piratebox-diy-openwrt
  • Pour la personnalisation de la Piratebox merci à Sylvain Naudin et Thomas Fourmeux pour leurs articles :

  • http://biblionumericus.fr/2013/07/06/personnaliser-sa-piratebox
  • http://sylvain.naud.in/post/2013/06/15/Personnaliser-votre-PirateBox-avec-Bootstrap
  • http://sylvain.naud.in/post/2013/06/16/Personnaliser-le-r%C3%A9pertoire-Lighttpd-de-votre-PirateBox

    Installation de la Piratebox :

    (Source David Darts)

    Vous aurez besoin de :

  • TP-Link MR3020
  • Clé Usb (formatée en FAT32 avec une seule partition)
  • Un câble Ethernet

    Installation d’OpenWRT :

    Ce tutoriel a été testé avec un Mac sous OSX 10.8. Toutefois ces instructions fonctionneront également sous Linux ou Windows (utilisez PuTTY)

    1 Téléchargez une version modifiée d’OpenWrt pour le MR3020 (réalisée par Matthias Strubel).

    2 Mettez l’interrupteur du MR3020 sur WISP

    3 Désactivez le Wifi de votre ordinateur

    4 Connectez le routeur par le câble ethernet à votre ordinateur et ouvrez votre navigateur à l’adresse : http://192.168.0.254

    5 Indiquez les login et mot de passe par défaut (admin & admin)

    6 Cliquez ensuite sur System Tools > Firmware Upgrade et sélectionnez le firmware OpenWRT téléchargé à l’étape 1.

    7 Après la mise à jour, le système redémarre.

    8 Dans votre Terminal entrez la commande suivante : telnet 192.168.1.1

    9 Entrez la commande passwd pour indiquer votre mot de passe, cela activera le SSH :

    passwd

    NOTE : rien ne s’affichera lorsque vous taperez votre mot de passe, c’est normal

    10 Modifiez le fichier de configuration du réseau avec vi :

    NOTE: Si vous n’êtes pas familiarisé avec vi consultez ce site : http://www.lagmonster.org/docs/vi.html

    Les instructions suivantes supposent que l’adresse IP de la box (passerelle) de votre réseau domestique est : 192.168.2.1. Si votre box possède une adresse différente, vous devrez modifier le fichier de configuration du réseau en conséquence.

    Gardez à l’esprit que votre routeur MR3020 ne doit pas avoir la même adresse que votre box, quoiqu’ils aient besoin d’être sur la même plage d’adresse IP pour accéder au contenu de la biblioboîte et télécharger les fichiers.

    Pour l’adresse des DNS vous pouvez utiliser les DNS de votre FAI ou des adresses DNS publiques (ici sont renseignées les adresses DNS de google)

    vi /etc/config/network
    
    

    Une fois modifié, le fichier doit ressembler à ça :

    config interface 'loopback'                                                               
            option ifname 'lo'                                                                                                                                        
            option ipaddr '127.0.0.1'                                                         
            option netmask '255.0.0.0'                                                        
    
    config interface 'lan'                                                                    
            option ifname 'eth0'                                                              
            option type 'bridge'                                                              
            option proto 'static'                                                             
            option ipaddr '192.168.2.111'                                                       
            option netmask '255.255.255.0'                                                    
            option gateway '192.168.2.1'                                                     
            list dns '8.8.4.4’                                                           
            list dns '8.8.8.8'
    
    

    11 Débranchez le routeur MR3020

    12 Activez le wifi sur votre ordinateur.

    13 Connectez le MR3020 par le câble ethernet à votre box (ou routeur domestique) et rebranchez-le. Attendez quelques minutes que le MR3020 démarre. Avec votre ordinateur connecté à votre réseau domestique essayez d’accéder par ssh au MR3020 :

    ssh root@192.168.2.111 

    Note : Utilisez l’adresse renseignée dans “ipaddr” à l’étape 9

    14 Effectuez un Ping sur google.com pour vous assurer que la configuration de votre parefeu est correcte :

     ping google.com 

    NOTE : Ctrl C pour arrêter les requêtes

    15 Ajoutez le support USB à OpenWrt en installant les paquets suivants :

    opkg update
    opkg install kmod-usb-uhci
    insmod usbcore 
    insmod uhci
    opkg install kmod-usb-ohci 
    insmod usb-ohci
    
    

    NOTE : Cette étape n’est pas obligatoire si vous avez utilisé l’image modifié d’OpenWrt de l’étape 1

    Installation de Piratebox

    Nous allons maintenant installer Piratebox sur votre routeur MR3020.

    16 Branchez votre clé USB (formatée en FAT32 avec une seule partition) au port USB du MR3020

    17 Installez le paquet mkPirateBox avec les commandes suivantes :

    cd /tmp opkg update && opkg install http://piratebox.aod-rpg.de/piratebox_0.6.3_all.ipk

    18 Une fois l’installation terminée, débranchez le câble ethernet , l’alimentation et patientez 10 secondes au moins.

    19 Redémarrez l’appareil et connectez vous au réseau “PirateBox – Share Freely”. Ouvrez n’importe quel page et vous serez redirigé vers la page d’accueil de la Piratebox.

    Note : Piratebox ne prend en charge que le protocole http, si vous essayez d’ouvrir une page en mode sécurisé https la redirection vers la page d’accueil ne se fera pas.

    Transformation en Biblioboîte

    Félicitations vous avez une Piratebox. L’interface est un peu aride, pour la personnaliser et faire en sorte que son affichage s’adapte sur n’importe quel terminal nous allons installer bootstrap le framework de Twitter [modifié par Sylvain Naudin] pour la piratebox.

    Pour notre version de la biblioboîte nous avons supprimé le chat et la possibilité de charger des fichiers pour les utilisateurs. Vous pouvez télécharger notre version modifiée du dossier à cette adresse ou télécharger la version de Sylvain Naudin sur son site.

    Personnaliser avec bootstrap

    (source Thomas Fourmeux)

    20 Téléchargez le dossier

    21 Connectez vous au réseau wifi de votre PirateBox

    22 Copiez les fichiers depuis votre PC dans le dossier /opt/piratebox/www de votre MR3020. Remplacez le fichier index.html et ajoutez le fichier piratebox.html ainsi que le dossier nod1 et son contenu :

    scp /chemin/de/votre/fichier.txt root@192.168.1.1:/opt/piratebox/www 

    Note : sous Windows vous pouvez utiliser WinSCP et sous Mac OS Fugu. N’oubliez pas d’indiquer le numéro du port 22, en login : root et le mot de passe renseigné à l’étape 9

    23 Une fois les fichiers chargés redémarrez votre piratebox

     
    /etc/init.d/piratebox stop
    /etc/init.d/piratebox start 
    
    24 Connectez vous à votre PirateBox et admirez le résultat !

    Personnaliser lighttpd

    (Source : Sylvain Naudin)

    Nous allons maintenant personnaliser la page serveur par défaut de lighttpd qui affiche la liste des fichers et dossiers de votre Piratebox. Toujours basé sur le travail de sylvain Naudin vous pouvez télécharger ses fichiers ou utiliser ceux de la biblioboîte légèrement modifiés.

    25 Connectez vous au réseau wifi de votre Piratebox

    26 Ouvrez le terminal et connectez vous par ssh

    ssh root@192.168.1.1 

    27 Modifier le fichier lighttpd.conf :

    vi /opt/piratebox/conf/lighttpd/lighttpd.conf

    28 Ajoutez ensuite les lignes pour gérer l’en-tête de l’index :

    dir-listing.auto-layout ="disable" 
    dir-listing.show-header ="enable" 
    dir-listing.hide-header-file ="enable" 
    dir-listing.encode-header ="disable"
    

    Note : Si vous voyez apparaitre un double de vos fichiers commençant par ._nomdufichier.epub ajoutez également cette ligne :

    dir-listing.hide-dotfiles=”enable”
    29 Pour gérer un pied de page ajoutez ces lignes :

    dir-listing.show-readme ="enable" 
    dir-listing.hide-readme-file ="enable" 
    dir-listing.encode-readme ="disable"
    

    30 Sauvegardez vos modifications, puis redémarrez votre PirateBox :

     /etc/init.d/piratebox stop /etc/init.d/piratebox start

    31 Ensuite, il nous reste à ajouter à votre répertoire Shared (l’espace de téléchargement par défaut de la PirateBox) le fichier HEADER.txt pour l’en-tête et le README.txt pour le pied de page.

    Note : Si vous avez des sous-dossiers, il faudra simplement faire une copie des fichiers HEADER.txt et README.txt, par exemple :

    cp /opt/piratebox/share/Shared/HEADER.txt /opt/piratebox/share/Shared/PDF/
    Note: si vous utilisez la version biblioboîte pensez à renommer le dossier “PDF” en “Livres” dans le dossier Shared de votre clé usb.

    Personnaliser le SSID

    Par défaut le nom du réseau wifi de votre PirateBox est ‘PirateBox - Share freely’. Si vous souhaitez le modifier suivez les indications suivantes :

    32 Connectez vous au réseau wifi de votre Piratebox

    33 Ouvrez le terminal et connectez vous par ssh

    ssh root@192.168.1.1 

    34 Arrêtez les scripts piratebox :

    /etc/init.d/piratebox stop 

    35 Modifiez le fichier de configuration du réseau :

    vi /etc/config/wireless 

    36 Remplacez le nom du réseau: option ssid ‘PirateBox – Share Freely’ par le nom désiré

    37 Enregistrez les modifications

    38 Relancez les scripts piratebox :

    /etc/init.d/piratebox start

    Quelques conseils d'utilisation

    Pour ajouter et retirer des documents, ne retirez jamais la clé USB de votre Biblioboîte lorsque celle ci est en marche.

    Avant de débrancher la Biblioboîte, arrêtez les scripts piratebox :

    /etc/init.d/piratebox stop 

    Débranchez ensuite l’alimentation

    Branchez votre clé USB sur votre ordinateur, placez les documents dans le dossier ‘Shared’.

    Note : En cas de création de dossier et sous dossier pensez à copier les fichiers HEADER.txt et README.txt afin de garder la personnalisation de l’affichage des documents.

    Liens utiles

    Présentation de la PirateBox par David Darts

    Créer une PirateBox

    Forum PirateBox

    Le Projet LibraryBox

    Page Bibliopedia dédiée aux BiblioBox

    Présentation de la BiblioBoîte